Menu Toggle

Aktuelle Einschränkungen

  • Mobil Es kommt zu Verzögerungen bei der Auslieferung von SMS, überregional/SMS Benachrichtigungen der Mailbox sind auch betroffen.
  • MeinVodafone im Web: Selfservice MeinVodafone im Web Registrierung/Hinzufügen von Verträgen.
  • Mobil: Aktuell kann es zu Einschränkungen, bei der Nutzung des Mobilen Hotspots bei iOS Geräten kommen.
  • Mobil: Bei Huawei Mifi Routern und Embedded Modulen, kann es zu falschen APN Einstellungen kommen. 

Nähere Infos dazu findest Du im Eilmeldungsboard.

Close announcement

Archiv_Internet-Geräte

Siehe neueste

cbn CH6640E: MAC-Weiterleitung, öffentliche IPv4, IPv6

GELÖST
Gehe zu Lösung
Highlighted
Smart-Analyzer

Mit dem Internet&Phone Neuvertrag xxxxxxxx bekam ich einen neuen Router von cbn CH6640E (Hardware 1.0, Firmware CH6640-4.5.0.5-NOSH). Ich habe damit versucht, den Port 22 (ssh) der MAC-Adresse eines meiner Computer (raspberry) vom Internet aus erreichbar zu machen. Dazu habe ich in der Weboberfläche des cbn die unter LAN-Benutzer angezeigte MAC in MAC-Weiterleitung eingetragen und Port22 aktiviert. Anschließend konnte ich aber mit Putty und der IP aus www.wieistmeineip.de nicht von aussen zugreifen. Mit dem alten Thomson-Kabelmodem von KD und meinem eigenen Netscape Router ging das früher. Haben Sie einen Tipp? Stimmt was nicht mit der IP ("nicht öffentlich")? Muss ich da versuchsweise den Bridge Mode aktivieren? Der neue Router ist sonst bezüglich MAC-Weiterleitung oder DynDNS nicht zu gebrauchen ...

 

Ich habe auch versucht, einen Webserver, der auf Port 5000 läuft, per MAC-Weiterleitung nach aussen zu leiten. Anschließend versuchte ich im Browser http://[meine globale IPv6-Adresse aus dem cbn-webinterface]:5000 . Funktioniert auch nicht. Kann ich mit IPv6 den Bridge Mode vermeiden?

 

Was mir auf de cbn-Webinterface noch auffiel: Systeminformation zeigt MAC-Adressen mit Bindestrichen, LAN-Benutzer zeigt sie mit Doppelpunkten formatiert ... Wie muss ich jetzt in MAC-Weiterleitung eintragen? Eine kleine Anleitung zu diesem Thema fände ich echt nützlich.

 

Edit: Vertragsnummer entfernt bitte keine persönlichen Daten in einem öffentlichen Forum posten.

Mehr anzeigen
1 Akzeptierte Lösung

Akzeptierte Lösungen
Highlighted
Smart-Analyzer

Oje, jetzt ist's auch mir aufgefallen, die einfache Lösung: der Win-PC hatte IPv6 disabled ...

Ping, Putty und http://[ip6-Adresse des RPi] gehen jetzt lokal von diesem PC aus ...Frustrierte Smiley

Lösung in ursprünglichem Beitrag anzeigen

Mehr anzeigen
9 Antworten 9
Highlighted
SuperUser

Die IPv6, die dir wieistmeineip.de anzeigt, ist die von deinem Rechner - und nicht die vom Raspberry!

Die IPv6, die dir das CBN-Webinterface anzeigt, ist die vom Router - ebenfalls nicht die vom Raspberry!

 

Da du per IPv6 auf den Raspberry zugreifen willst, musst du auch die IPv6 vom Raspberry eingeben!

Sprich http://[globale IPv6 des Raspberry]:5000 - in deinem Beispiel.

 

NICHT! die IPv6 vom CBN, nicht die von deinem Rechner, sondern die voom Raspberry!

Mehr anzeigen
Highlighted
SuperUser
Habe den Thread mal hierher verschoben. "Über Gott und die Welt" fand ich nicht passend.
Mehr anzeigen
Highlighted
Moderator

Hey,

 

hast Du die Tipps von @reneromann mal getestet?

 

LG

 

Tobias



Netz-Assistent How To Hilfe !

Bewertet hilfreiche Beiträge mit Likes und Sternen!
Unaufgeforderte PNs werden nicht beantwortet - Bitte erstellt einen Thread. Die Community hilft!
#bleibtgesund

Mehr anzeigen
Highlighted
Smart-Analyzer

Vielen Dank für die schnelle Antwort, leider hatte ich so schnell nicht Zeit. Du hast recht, aus der IPv4-Welt kommend ist bei IPv6 ein Umdenken wegen der fehlenden NAT nötig. Trotzdem, ich komm weder in Putty noch im Browser mit IPv6 bisher zurecht:

 

> im Netscape-Router WNDR3700 IPv6 aktiviert (sichere Filterung und offene probiert, "pass through" und "6to4 tunnel"), RPi und Win10-PC hängen ausgangsseitig an diesem Router im selben Netz.
> Webserver auf RPi gestartet (Port 5000), netstat -aln |grep 5000 -> "tcp 0.0.0.0:* listen"
> im Win-Browser (Chrome v66) http://192.168.X.XX:5000/ geht! (genaue IPv4 Adresse hier durch XX verdeckt)
> IPv6-Adresse des RPi aus ifconfig (eth0) kopiert (Putty Terminal).
> im Win-Browser nicht erreichbar, weder lokale noch globale IPv6: http://[fe80::XXXX:XXXX:XXXX:XXXX]:5000 (genaue Adresse hier durch XX verdeckt).
Funktioniert also nicht mal im lokalen Netz... Wo ist der Denkfehler? Wohl ein Routerproblem?

Mehr anzeigen
Highlighted
SuperUser

Wenn bei "netstat -aln |grep 5000" nur eine Zeile mit "tcp 0.0.0.0:5000 0.0.0.0:* listen" kommt und keine zweite Zeile mit "tcp6 :::5000 :::* listen" kommt, dann hört dein Webserver ausschließlich auf IPv4 und du kannst es vergessen, irgendwas per IPv6 zu erreichen.

 

By the way: IPv4-Adressen aus deinem privaten Netzwerk (192.168.x.x) kannst du ohne Probleme veröffentlichen - die sind nicht global routbar und daher für alle anderen Forenteilnehmer nicht zugreifbar.

Mehr anzeigen
Highlighted
Smart-Analyzer

Jetzt hast Du mir Hoffnungen gemacht, besten Dank für die Tipps ... Ich habe also folgendes probiert:

 

> ifconfig auf RPi zeigt nach Routerumstellung auf "IPv6 pass through, offen" die globale IPv6 neben der lokalen
> netstat -aln |grep tcp6 => zeigt auf dem RPi "tcp6 :::22 listen"
> putty (version 0.70) mit Eintrag fe80::XXXX:XXXX:XXXX:XXXX (Port 22) geht nicht (auch nicht mit Brackets [ipv6-adress]), nichts über ipv6 in putty Hilfe
> ping fe80::XXXX:XXXX:XXXX:XXXX am Win10-PC zeigt "Allgemeiner Fehler" (auch bei Option ping -6, ping6 gibts nicht), am RPi zeigt es "invalid argument"
> ping [fe80::XXXX:XXXX:XXXX:XXXX] am RPi zeigt "name or service not known", auf winPC wieder "Allgemeiner Fehler"
> dann auch noch Python Webserver auf IPv6 (in Flask app.run()) gestellt, jetzt zeigt netstat auf RPi auch "tcp6 :::5000 listen". Aber Chrome v66 aus winPC wieder ohne Erfolg mit http://[fe80::XXXX:XXXX:XXXX:XXXX]:5000

 

Sag nicht, ich habe mich nicht bemüht ...

Mehr anzeigen
Highlighted
Smart-Analyzer

Oje, jetzt ist's auch mir aufgefallen, die einfache Lösung: der Win-PC hatte IPv6 disabled ...

Ping, Putty und http://[ip6-Adresse des RPi] gehen jetzt lokal von diesem PC aus ...Frustrierte Smiley

Lösung in ursprünglichem Beitrag anzeigen

Mehr anzeigen
Highlighted
Smart-Analyzer

Noch eine abschliessende Frage:

 

> meine Konfiguration: ISP(Vodafone) - cbnRouter - netscapeRouter(WLAN) - Raspberry(RPi)

 

> Das NetscapeRouter-Webinterface zeigt unter IPv6 eine WAN-Adresse (2002:XXX...) an. Die Adresse hat sich der Netscape gegeben, nachdem er unter Autokonfig selbst einen 6to4 Tunnel eingestellt hat. Diese WAN-Adresse wird aber nicht unter LAN-Benutzer des cbnRouters angezeigt. Dort steht nur eine IPv4-Adresse des Netscape, aber keine IPv6. Vielleicht liegt sie ausserhalb seines IPv6-DHCP-Bereichs?


> Ziel ist natürlich die Erreichbarkeit des RPi von aussen, was ich über Smartphone teste (WLAN am Phone deaktiviert, http://[globale ipv6 des RPi]:5000). MAC-Weiterleitung von Netscape und Raspberry im cbn auf 5000 testweise aktiviert (gefährlich? NetscapeRouter-Webinterface aus Internet zugänglich?).

Mehr anzeigen
Highlighted
Moderatorin

Hallo her6,

 

schön, dass Dir mit den Tipps bereits geholfen werden konnte.

 

Ich Denke zu Deiner abschließenden Frage kommen von den Experten auch noch Hilfestellungen.

Ich lasse den Beitrag noch offen, bis alles geklärt ist.

 

Viele Grüße, Manu


#Stayhome und bleibt gesund
Zeigt, welche Beiträge Ihr cool findet – klickt auf „Gefällt mir“!


Alles Easy How To Hilfe !

Unaufgeforderte PNs werden nicht beantwortet. Bitte erstellt einen Thread, wenn Ihr Hilfe benötigt. Wir kümmern uns darum.

Mehr anzeigen
Top Autoren