Menu Toggle

Aktuelle Einschränkungen:

 

Kabel: Ankündigung Ausfall aufgrund von Wartungsarbeiten (20. September)

Kabel: Ankündigung Ausfall aufgrund von Wartungsarbeiten (21. September)

Kabel: Ankündigung Ausfall aufgrund von Wartungsarbeiten (22. September)

Kabel: Ankündigung Ausfall aufgrund von Wartungsarbeiten (23. September)

Kabel: Ankündigung Ausfall aufgrund von Wartungsarbeiten (24. September)

Kabel, DSL, Mobil  Ausfälle aufgrund von Hochwasser

 

Nähere Informationen dazu findet Ihr im Eilmeldungsboard

Close announcement

Internet-Geräte

Siehe neueste
Betreff: Vodafon Station IPv6 Host Exposure scheint keinen Effekt zu haben
sea212
Smart-Analyzer

Hallo liebe Community,

 

ich möchte einen Dienst über IPv6 anbieten. Der Router (Vodafon Station) blockiert selbstverständlich alle eingehenden Verbindungen, allerdings lässt sich diese Firewall bei mir nicht wie erwartet über IPv6 Host Exposure konfigurieren. Eine deaktivierte Firewall macht den Dienst erreichbar, ist allerdings im meinem aktuellen Aufbau keine Option. Bin dankbar für jede Hilfe.

 

Szenario: Gerät im Netzwerk mit statischer IPv6 Adresse lässt einen Dienst auf Port 9987 laufen. Mittels IPv6 host Exposure soll das Gerät nun Datenpakete, die an diesen Port gerichtet sind und meinen Router erreichen, empfangen können. Das passiert jedoch nicht.

Vodafon Station Firmware-Version: 01.02.068.11.EURO.SIP

 

Fall 1: IPv6 port scan mit IPv6 Host Exposure

IPv6 Host Exposure KonfigurationIPv6 Host Exposure Konfiguration

Das dort angegeben Gerät ist erreichbar, hat eine statische IPv6 Addresse und bietet den Dienst auf dem angebenen Port an. Dieser kann im privaten lokalen Netz, oder aus dem öffentlichen Netz mit deaktivierter Firewall, erfolgreich in Anspruch genommen werden.

----------------------------------------------------

Firewall: anFirewall: an

----------------------------------------------------

http://www.ipv6scanner.com/ 

 

Port: Vom Router blockiertPort: Vom Router blockiert

Der Router blockiert Anfragen auf 9987. Mein Endgerät kommt nicht in Frage, denn dieses ist über jenen Port bei deaktivierter Firewall erreichbar.

 

Fall 2: IPv6 port scan mit deaktiverter Firewall

Firewall: AusFirewall: Aus

----------------------------------------------------

http://www.ipv6scanner.com/ 

 

Port: Wird nicht von Router blockiertPort: Wird nicht von Router blockiert

Der Port wird nun vom Router nicht blockiert. Dort steht zwar, das keine Applikation auf diesen Port hört, das stimmt jedoch nicht. Nach deaktivierung der Firewall kann ich aus dem isolierten Gast-WLAN auf den Dienst zugreifen und ein Freund kann von seinem (von meinem isolierten) Heimnetz ebenfalls den Dienst nutzen.

 

Danke im Voraus für jede Hilfe.

 

Nachträgliche Anmerkungen: In der Ergebnistabelle des Portscans steht "TCP", allerdings habe ich bei der Anfrage "UDP" angegeben. Bin mir jetzt nicht sicher ob das nur ein Anzeigefehler ist. Um das auszuschließen, habe ich Testweise beim IPv6 Host Exposure den Port 9987 auf TCP/UDP gestellt. In dem Fall wird er auch gefiltert.

Mehr anzeigen
14 Antworten 14
RobertP
Giga-Genie

das sieht nach einem Bug aus Smiley (traurig)

das Einzige was du versuchen kannst ist ein vollständiger Werksreset  (Reset für min. 20 Sekunden gedrückt halten)

 

Gruß Robert 

Mehr anzeigen
sea212
Smart-Analyzer

Hallo Robert,

 

danke für deinen Vorschlag. Habe alle Daten gespeichert, einen Werksreset durchgeführt und den Router neu konfiguriert. Es stellt sich heraus, das TCP Ports nun geöffnet werden können, UDP Ports jedoch leider nicht. Ich habe das auch für IPv4 Port Forwarding ausprobiert - gleiches Ergebnis, TCP kann geöffnet werden, UDP nicht.

 

Das ist nicht so Seitens Vodafone gewollt, oder? Letztendlich kann man das alles mit einer deaktivierten Firewall ja umgehen (was man selbstverständlich nicht ohne vernünftige alternative Löung machen sollte). Ich vermute ein Fehler im Router selber (Hardware-Fehler) ist sehr unwahrscheinlich. Wenn es allerdings an der Firmware liegen sollte, dann müsste ich ja nicht der einzige mit solch einem Problem sein.

 

Bin mir gerade nicht ganz sicher wie ich weiter vorgehen soll. Ich hatte heute drei Telefonate mit Vodafone, wovon eines direkt hilfreich war und zwei indirekt hilfreich waren, indem mir (vernünftigerweise) beschrieben wurde, was ich tun soll um an einen Experten im dem Bereich bei Vodafone zu gelangen. Das hat leider nicht so gut geklappt, also es ist schwer gewesen jemanden zu erreichen, die/der versteht was ich von ihr/ihm möchte. Gibt es da einen erfolgsversprechenderen Weg?

 

Nachtrag 1: Manchmal werden TCP Ports auf IPv6 immernoch blockiert. Habe noch nicht herausgefunden, welche Umstände dazu führen

Nachtrag 2: Die Firewall auszuschalten bezweckt nun nichts mehr. Mit ausgeschalteter Firewall werden Anfragen auf alle Ports, egal ob über IPv4 oder IPv6, nun vom Router gefiltert.

Mehr anzeigen
RobertP
Giga-Genie

Denke auch, daß es sich um einen Fehler in der Firmware handelt.

Bei Vodafone dauert es oft lange bis solche Fehler behoben werden.

Ein Vodafone Experte wird dir da auch nicht weiterhelfen können.

Gruß Robert

Mehr anzeigen
sea212
Smart-Analyzer

Da hast Du recht, ich sollte nicht weiter Ressourcen von Vodafone verbrauchen wenn schon recht klar ist, das mir dort direkt niemand helfen kann. Was allerdings noch sehr hilfreich wäre, wäre zu wissen wo man einen Bug-Report für die Entwickler erstellen kann.

Mehr anzeigen
RobertP
Giga-Genie

Hallo,

da die Firmware vom Hersteller entwickelt wird, müsstest du deinen Bug Report ja dahin schicken und die nehmen von Endkunden keine Reports an.

Vielleicht kann ein Moderator den Fehler weiterleiten.

Gruß Robert

Mehr anzeigen
Tina
Moderatorin

Hallo sea212,

 

damit ich das an die Kollegen weitergeben kann, brauch ich Deine Deine Kundennummer, Name, Geburtsdatum und Anschrift. Sende mir alles in einer Privatnachricht zu und melde Dich bitte noch einmal kurz in Deinem Beitrag.

 

Beste Grüße

Tina

 

   

#Stayhome und bleibt gesund
Zeigt, welche Beiträge Ihr cool findet – klickt auf „Gefällt mir“!


Alles Easy How To Hilfe !

Unaufgeforderte PNs werden nicht beantwortet. Bitte erstellt einen Thread, wenn Ihr Hilfe benötigt. Wir kümmern uns darum.

Mehr anzeigen
Chris2301
Digitalisierer

@sea212 Ich möchte mich ungefragter Weise anhängen. Kannst du Neuigkeiten berichten?

Kann das "Fehlerbild" aus Nachtrag 2 jedenfalls so bestätigen. Ferner ist es offenbar unmöglich, eingetragene Host Exposures zu löschen oder zurückzusetzen.

 

#Bug1 - Host Exposures unlöschbar

 

Schritte zur Reproduktion des Fehlers:

- Login unter 192.168.0.1

- Auswahl "Experten-Modus"

- Auf der Übersichtsseite wird auf "Internet" geklickt

- Auf der jetzt geladenen Seite wird auf "IPv6 Host Exposure" geklickt

- Bei der Host Exposure wird auf das Icon "Mülltonne" geklickt

- Die Host Exposure wird aus der Liste genommen

- Es wird auf "Anwenden" geklickt

- Die Seite lädt neu

- Die Host Exposure ist wieder da

 

Erwartetes Ergebnis:
Die Host Exposure ist gelöscht

 

Tatsächliches Ergebnis:

Die Host Exposure bleibt bestehen

 

Workaround:

Unbekannt

 

#Bug2 - Host Exposures nicht zurücksetzbar

 

Schritte zur Reproduktion des Fehlers:

- Login unter 192.168.0.1

- Auswahl "Experten-Modus"

- Auf der Übersichtsseite wird auf "Internet" geklickt

- Auf der jetzt geladenen Seite wird auf "IPv6 Host Exposure" geklickt

- Es wird auf den weißen Button "Zurücksetzen" geklickt

- Es wird auf den nun erscheinenden lila Button "Zurücksetzen" geklickt

- Die Seite lädt neu mit dem kompletten Inhalt, der zuvor auch da war.

 

Erwartetes Ergebnis:
Alle Host Exposures sind entfernt.

 

Tatsächliches Ergebnis:

Alle Host Exposure bleiben bestehen

 

Workaround:

Unbekannt

 

Ich habe noch nicht getestet, ob der An/Aus-Schieber überhaupt eine Funktion hat. Falls der nicht funktional wäre, reden wir langsam von einem sicherheitsrelevanten Problem.

 

 

(1)
Mehr anzeigen
sea212
Smart-Analyzer

Hallo @Chris2301 ,

 

ich kann leider keine guten Neuigkeiten berichten, habe alles was mir so einfiel ausprobiert und irgendwann aufgegeben. Wenn ich mich recht erinnere hat es geklappt ports für TCP Pakete freizugeben, UDP Pakete wurden leider immer gefiltert. Es scheint tatsächlich ein fieser Bug zu sein, und leider nicht der einzige. Ich bin jedoch sehr glücklick darüber, dass IPv4 Port-Forwarding immerhin bislang problemlos funktioniert hat.

 

Zu dem Bugs über die du berichtet hast: Diese Fehler sind bei mir auch aufgetreten. Manchmal konnte ich die Einträge löschen, manchmal widerrum nicht. Ich weiß nicht welche Umstände zu dieser Situation führen.

Mehr anzeigen
BobbyTables
Smart-Analyzer

Gibt es hierzu etwas Neues?

Host Exposure hat aktuell keinen Effekt.

Getestet mit TCP und UDP, keine Antwort (filtered).

Einträge lassen sich wie hier beschreiben nicht löschen.

Firmware-Version: 01.02.068.11.EURO.SIP

 

Brige Mode lässt sich ebenfalls nicht aktivieren Red Internet & Phone 100 Cable U (ehemaliges Unitymedia Netz)

Es ist aktuell also NICHT MÖGLICH von außen eine Verbindung zum Heimnetz aufzubauen! Smiley (wütend)

Was leider gerda aktuell für so manche VPN Anwendung unerlässlich ist.

Da ich so momentan erhebliche Einschränkungen im Homeoffice hinnehmen muss spiele ich mit dem Gedanke hier einfach zu kündigen und zu Telekom DSL mit IPv4 Adresse zu wechseln... Ich würde gern bei IPv6 bleiben, Verbindungsqualität ist wirklich gut aber mit dieser Schrott Software, dem Vertrags- und Portaljungel auf der Webseite verliere ich langsam die Geduld...

Mehr anzeigen